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ModusToolbox™ tools package version 3.2.0 

A newer version of this document may be available on the web here. 

About this document 

Scope and purpose 

ModusToolbox™ software is a set of tools and libraries that support device configuration and application 
development. These tools enable you to integrate our devices into your existing development methodology. 
This document provides information and instructions for using Keil µVision with ModusToolbox™ software. 

Document conventions 

Convention Explanation 

Bold Emphasizes heading levels, column headings, menus and sub-menus. 

Italics Denotes file names and paths. 

Courier New Denotes APIs, functions, interrupt handlers, events, data types, error handlers, file/folder names, 

directories, command line inputs, code snippets. 

File > New Indicates that a cascading sub-menu opens when you select a menu item. 

Reference documents 

Refer to the following documents for more information as needed: 

• ModusToolbox™ tools package installation guide –Provides information and instructions about installing 

the tools package on Windows, Linux, and macOS. 

• ModusToolbox™ tools package user guide –Provides information about all the tools included with 

ModusToolbox™ tools package. 

• Dashboard user guide –Provides specific information about the Dashboard tool. 

• Project Creator user guide –Provides specific information about the Project Creator tool. 

• Device Configurator guide –Provides specific information about the Device Configurator. 

 

https://www.infineon.com/MTBuVisionUserGuide
http://www.infineon.com/ModusToolboxInstallGuide
https://www.infineon.com/ModusToolboxUserGuide
http://www.infineon.com/ModusToolboxDashboard
https://www.infineon.com/ModusToolboxProjectCreator
https://www.infineon.com/ModusToolboxDeviceConfig
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Download/install software 

1 Download/install software 

1.1 ModusToolbox™ tools package 

Refer to the instructions in the ModusToolbox™ tools package installation guide for how to download and 
install the ModusToolbox™ tools package. 

1.2 Keil µVision (Windows only) 

Keil µVision version 5.30 or later 

1.3 J-Link 

For J-Link debugging, download and install J-Link software: 

https://www.segger.com/downloads/J-Link/J-Link_Windows.exe 

 

 

http://www.infineon.com/ModusToolboxInstallGuide
https://www.segger.com/downloads/jlink/JLink_Windows.exe
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2 Getting Started 

This section covers the ways to get started using IAR Embedded Workbench with ModusToolbox™ software. 

• Create new application 

• Exporting existing application 

• Open application Keil µVision 

2.1 Create new application 

Creating an application includes several steps, as follows: 

2.1.1 Step 1: Open Project Creator tool 

The ModusToolbox™ Project Creator tool is used to create applications based on code examples and template 
applications. You can open the Project Creator tool from the Windows Start menu, or by launching the 

executable. By default, the tool is installed in the following directory: 

<user_home>/ModusToolbox/tools_<version>/project-creator 

The tool is provided in GUI form and as a command line interface. For more details, refer to the Project Creator 

user guide. 

Note: You can also launch the Project Creator tool from the ModusToolbox™ Dashboard. Refer to the 
Dashboard user guide for details. 

2.1.2 Step 2: Choose Board Support Package (BSP)  

When the Project Creator tool opens, expand one of the BSP categories under Kit Name and select an 
appropriate kit; see the description for it on the right. The following image is an example; the precise list of 

boards available in this version will reflect the platforms available for development. You can also create a new 
BSP or browse for one on disk. 

 

For this example, select the CY8CKIT-062S2-43012 kit. 

http://www.infineon.com/ModusToolboxProjectCreator
http://www.infineon.com/ModusToolboxProjectCreator
http://www.infineon.com/ModusToolboxDashboard
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2.1.3 Step 3: Select application 

Click Next > to open the Select Application page.  

 

This page displays example applications, which demonstrate different features available on the selected BSP. 

In this case, the CY8CKIT-062S2-43012 provides the PSoC™ 62 MCU and the AIROC™ CYW43012 Wi-Fi & 
Bluetooth® combo chip. You can create examples for PSoC™ 6 MCU resources such as CAPSENSE™ and QSPI, as 

well as numerous examples for other capabilities. 

Click Browse… next to Application(s) Root Path to create or specify a folder where the application will be 
created. 

Pull down the Target IDE menu, and select ARM MDK (uVision). 

 

Under the Template Application column, expand Getting Started and select Hello World from the list. This 

example exercise uses the PSoC™ 6 MCU to blink an LED. 

 

The actual application names available might vary. 

Type a name for your application and/or BSP, or leave the default names. Do not use spaces. Also, do not use 
common illegal characters, such as: 

* . " ‘ / \ [ ] : ; | = ,  
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2.1.4 Step 4: Create application 

Click Create to start creating the application. The tool displays various messages. 

 

When the process completes, a message states that the application was created. Click Close to exit the Project 

Creator tool. 

 

 

2.2 Export existing application 

If you have a ModusToolbox™ application that was created for another IDE or for the command line, you can 
export that application to be used in µVision. Open a terminal window in the application directory, and run the 
command make uvision TOOLCHAIN=ARM. 

Note: For applications that were created using core-make-3.0 or older, you must use the 

make uvision5 command instead. 

Note: This sets the TOOLCHAIN to ARM in the Keil µVision configuration files but not in the 
ModusToolbox™ application’s Makefile. Therefore, builds inside Keil µVision will use the ARM 

toolchain while builds from the ModusToolbox™ environment will continue to use the toolchain 
that was previously specified in the Makefile. You can edit the Makefile’s TOOLCHAIN variable if 

you also want ModusToolbox™ builds to use the ARM toolchain. 

Note: Check the output log for instructions and information about various flags. 



  

User guide 7 002-37570 Rev. *B  

  2024-01-25 

Keil µVision for ModusToolbox™ user guide 
  

Getting Started 

2.3 Open application in Keil µVision 

Creating or exporting the application generates the following file in the application directory:  

mtb-example-psoc6-hello-world.cprj  

The cprj file extension should have the association enabled to open it in Keil µVision. 

1. Double-click the mtb-example-psoc6-hello-world.cprj file. This launches the Keil µVision IDE. The first time 
you do this, the following dialog displays: 

 

2. Click Yes to install the device pack. You only need to do this once. 

3. Follow the steps in the Pack Installer to properly install the device pack. 

    

Note: In some cases, you may see the following error message: 

 

SSL caching disabled in Windows Internet settings. Switched to offline mode. 
 
See this link for how to solve this problem: 

https://developer.arm.com/documentation/ka002253/latest 

4. When complete, close the Pack Installer and close the Keil µVision IDE. 

5. Then double-click the .cprj file again and the application will be created for you in the IDE. 

https://developer.arm.com/documentation/ka002253/latest
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3 Configure and build the application 

1. Right-click on the mtb-example-psoc6-hello-world directory in the µVision Project view, and select Options 
for Target '<application-name>' … 

 

2. On the dialog, select the C/C++ (AC6) tab. 

• Check that the Language C version was automatically set to c99. 

• Select "AC5-like warnings" in the Warnings drop-down list. 

• Select "-Os balanced" in the Optimization drop-down list. 

• To reduce memory usage, select the One ELF Section per Function check box. 
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3. Select the Debug tab, and select KitProg3 CMSIS-DAP as an active debug adapter: 

 

4. Click OK to close the Options dialog. 

Note: For applications using the PSoC™ 64 MCU or AIROC™ CYW20829 device, skip the next step. Instead, 
perform the steps outlined in the applicable section. 

5. Select Project > Build target. 

 

To suppress the linker warnings about unused sections defined in the linker scripts, add "6314,6329" to the 

Disable Warnings setting in the Project Linker Options. 

 

3.1 PSoC™ 64 application configuration 

Before building an application for a PSoC™ 64 secure MCU in Keil µVision, you must perform the following 
configuration steps:  

1. Build the application using the ModusToolbox™ make build command. You can do this by using a Terminal 
or by exporting the application to Eclipse or VS Code. 
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2. Copy the post-build command from the log. For example: 

C:/Infineon/Tools/ModusToolbox/tools_3.1/python/python.exe C:/UG/CY8CPROTO-064S1-

SB_Secure_Blinky_LED_FreeRTOS_UG/bsps/TARGET_APP_CY8CPROTO-064S1-SB/psoc64_postbuild.py --

core CM4 --secure-boot-stage single --policy policy_single_CM0_CM4 --target cyb06xx7 --

toolchain-path C:/Infineon/Tools/ModusToolbox/tools_3.1/gcc --toolchain GCC_ARM --build-dir 

C:/UG/CY8CPROTO-064S1-SB_Secure_Blinky_LED_FreeRTOS_UG/build/APP_CY8CPROTO-064S1-SB/Debug -

-app-name mtb-example-psoc6-secure-blinkyled-freertos --cm0-app-path 

../mtb_shared/cat1cm0p/release-v1.0.0/COMPONENT_CAT1A/COMPONENT_CM0P_SECURE --cm0-app-name 

psoc6_01_cm0p_secure 

3. Paste the command into an appropriate editor, and make the following edits:  

• Change --toolchain-path to the ARM toolchain; for example, C:/Keil_v5/ARM/ARMCLANG  

• Change --toolchain to ARM  

• Change --build-dir to Keil µVision build directory 

 

Example of command after edit: 

C:/Infineon/Tools/ModusToolbox/tools_3.1/python/python.exe C:/UG/CY8CPROTO-064S1-

SB_Secure_Blinky_LED_FreeRTOS_UG/bsps/TARGET_APP_CY8CPROTO-064S1-SB/psoc64_postbuild.py 

--core CM4 --secure-boot-stage single --policy policy_single_CM0_CM4 --target cyb06xx7 

--toolchain-path C:/Keil_v5/ARM/ARMCLANG --toolchain ARM --build-dir C:/UG/CY8CPROTO-

064S1-SB_Secure_Blinky_LED_FreeRTOS_UG/mtb-example-psoc6-secure-blinkyled-

freertos_Objects --app-name mtb-example-psoc6-secure-blinkyled-freertos --cm0-app-path 

../mtb_shared/cat1cm0p/release-v1.0.0/COMPONENT_CAT1A/COMPONENT_CM0P_SECURE --cm0-app-

name psoc6_01_cm0p_secure 

4. Copy the edited command. 

5. In µVision, select Project > Options for Target 'Target 1'… to open the Options dialog. 

6. Select the User tab and enable the Run #1 check box under After Build/Rebuild. Then, paste the edited 
command. 
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7. Select the Output tab and enable the Create HEX File check box. 

 

8. On the same Output tab, add an ".elf" extension in the Name of Executable field. 

 

9. Create an empty project.ini file in the project root folder. 
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10. On the Options dialog, select the Utilities tab and select the project.ini file using the […] button. Then, click 
Edit to open the file and click OK to close the options dialog. 

 

11. Type LOAD $L@L.hex in the project.ini file and save the file. 

 

12. Select Project > Build Target to build the application and execute post-build commands. 

After performing these steps, you should be able to run debug, erase, and program for PSoC™ 64 secure MCUs. 

3.2 AIROC™ CYW20829 device configuration 

Before building an application for an AIROC™ CYW20829 device in Keil µVision, you must perform the following 
configuration steps:  

1. Create a postbuild.bat file in the root directory of the project.  

2. Add SET PATH=%PATH%;"/usr/bin" at the start of the file.  

3. Build the application using the ModusToolbox™ make build command. You can do this by using a Terminal 
or by exporting the application to Eclipse or VS Code. 
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4. Copy the post-build command output from the log. For example: 

C:/Infineon/Tools/ModusToolbox/tools_3.1/gcc/bin/arm-none-eabi-objcopy -O ihex 

C:/20829_keil/Hello_World/build/APP_CYW920829M2EVK-02/Debug/mtb-example-hal-hello-world.elf 

C:/20829_keil/Hello_World/build/APP_CYW920829M2EVK-02/Debug/mtb-example-hal-hello-world.hex 

 

C:/Infineon/Tools/ModusToolbox/tools_3.1/gcc/bin/arm-none-eabi-objcopy 

C:/20829_keil/Hello_World/build/APP_CYW920829M2EVK-02/Debug/mtb-example-hal-hello-world.elf 

-S -O binary C:/20829_keil/Hello_World/build/APP_CYW920829M2EVK-02/Debug/mtb-example-hal-

hello-world.bin; 

 

"C:/Infineon/Tools/ModusToolbox/tools_3.1/modus-shell/bin/bash.exe" --norc --noprofile 

../mtb_shared/recipe-make-cat1b/release-v2.2.1/make/scripts/20829/flash_postbuild.sh 

"GCC_ARM" "C:/20829_keil/Hello_World/build/APP_CYW920829M2EVK-02/Debug" "mtb-example-hal-

hello-world" "C:/Infineon/Tools/ModusToolbox/tools_3.1/gcc/bin" 

"C:/Infineon/Tools/ModusToolbox/tools_3.1/srecord/bin/srec_cat.exe" "0x00002400" 

 

"C:/Infineon/Tools/ModusToolbox/tools_3.1/modus-shell/bin/bash.exe" --norc --noprofile 

../mtb_shared/recipe-make-cat1b/release-v2.2.1/make/scripts/20829/run_toc2_generator.sh 

"NORMAL_NO_SECURE" "C:/20829_keil/Hello_World/build/APP_CYW920829M2EVK-02/Debug" "mtb-

example-hal-hello-world" "flash" "bsps/TARGET_APP_CYW920829M2EVK-02" "NONE" 

"C:/Infineon/Tools/ModusToolbox/tools_3.1/gcc" "" 0x20000 0 "" "0x00002400" "256" 

 

C:/Infineon/Tools/ModusToolbox/tools_3.1/srecord/bin/srec_cat.exe 

C:/20829_keil/Hello_World/build/APP_CYW920829M2EVK-02/Debug/mtb-example-hal-hello-

world.final.bin -Binary -offset 0x60000000 -o 

C:/20829_keil/Hello_World/build/APP_CYW920829M2EVK-02/Debug/mtb-example-hal-hello-

world.final.hex -Intel -Output_Block_Size=16 

 

rm -rf C:/20829_keil/Hello_World/build/APP_CYW920829M2EVK-02/Debug/mtb-example-hal-hello-

world.bin; 

5. Paste the command into the postbuild.bat file and make changes to the file to match the Keil UVision 

structure (changing paths to .elf and .hex files, etc.): 

Example of file after edit: 

SET PATH=%PATH%;"/usr/bin" 

"C:/Keil_v5/ARM/ARMCLANG/bin/fromelf" C:/20829_keil/Hello_World/mtb-example-hal-hello-

world_Objects/mtb-example-hal-hello-world.elf --bin --output=C:/20829_keil/Hello_World/mtb-

example-hal-hello-world_Objects/mtb-example-hal-hello-world.bin 

 

"C:/Infineon/Tools/ModusToolbox/tools_3.1/modus-shell/bin/bash.exe" --norc --noprofile 

../mtb_shared/recipe-make-cat1b/release-v2.2.1/make/scripts/20829/flash_postbuild.sh "ARM" 

"C:/20829_keil/Hello_World/mtb-example-hal-hello-world_Objects" "mtb-example-hal-hello-

world" "C:/Infineon/Tools/ModusToolbox/tools_3.1/gcc/bin" 

"C:/Infineon/Tools/ModusToolbox/tools_3.1/srecord/bin/srec_cat.exe" "0x00002400" 

 

"C:/Infineon/Tools/ModusToolbox/tools_3.1/modus-shell/bin/bash.exe" --norc --noprofile 

../mtb_shared/recipe-make-cat1b/release-v2.2.1/make/scripts/20829/run_toc2_generator.sh 

"NORMAL_NO_SECURE" "C:/20829_keil/Hello_World/mtb-example-hal-hello-world_Objects" "mtb-

example-hal-hello-world" "flash" "bsps/TARGET_APP_CYW920829M2EVK-02" "NONE" 

"C:/Infineon/Tools/ModusToolbox/tools_3.1/gcc" "" 0x20000 0 "" "0x00002400" "256" 

 

C:/Infineon/Tools/ModusToolbox/tools_3.1/srecord/bin/srec_cat.exe 

C:/20829_keil/Hello_World/mtb-example-hal-hello-world_Objects/mtb-example-hal-hello-

world.final.bin -Binary -offset 0x60000000 -o C:/20829_keil/Hello_World/mtb-example-hal-

hello-world_Objects/mtb-example-hal-hello-world.final.hex -Intel -Output_Block_Size=16 

 

del "C:\20829_keil\Hello_World\mtb-example-hal-hello-world_Objects\mtb-example-hal-hello-

world.bin" 

6. Save the postbuild.bat file. 
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7. Open the Project > Options for Target ‘Target 1’ dialog, select the User tab, select the After 
build/Rebuild run #1 check box, and select the postbuild.bat file: 

 

8. Select the Output tab and add a ".elf" extension to the file in the Name of Executable field: 

 

9. Create empty project.ini and project_2.ini files in the project root folder. 
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10. Select the Utilities tab, select the project.ini file in the Init File field, click the Edit button, and OK: 

 

11. Add the following text to the project.ini file and click Save: 

LOAD $L@L.final.hex 
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12. Reopen the Project > Options for Target ‘Target 1’ dialog and select the Debug tab. Make sure that the 
Load Application at Startup check box is not checked 

13. Select the project_2.ini file in the Initialization File field, click the Edit button, and OK: 

 

14. Add the follow text to the project_2.ini file and click Save. 

LOAD $L@L.elf NOCODE 

g, main 

 

  

15. Select Project > Build Target to build the application and execute post-build commands. 

After following these steps, you should be able to run Debug, Erase, and Program for the AIROC™ CYW20829 
device. 
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4 Programming/Debugging 

1. Connect the PSoC™ 6 kit to the host PC. 

2. As needed, run the fw-loader tool to make sure the board firmware is upgraded to KitProg3. See KitProg3 

User Guide for details. The tool is located in this directory by default: 

<user_home>/ModusToolbox/tools_3.1/fw-loader/bin/ 

3. Select Debug > Start/Stop Debug Session. 

 

https://www.infineon.com/documentation/development-kitsboards/kitprog-user-guide
https://www.infineon.com/documentation/development-kitsboards/kitprog-user-guide
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You can view the system and peripheral registers in the SVD view. 

 

 

4.1 To use KitProg3/MiniProg4, CMSIS-DAP, and ULink2 debuggers 

1. Select the Device tab in the Options for Target dialog and check that M4 core is selected: 
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2. Select the Debug tab.  

Note: To use the ULink2 probe for multi-core debugging, select the CMSIS-DAP Debugger instead of 

ULink for each core of the project (CM4 and CM0P). 

3. Click the Settings button. 

 

4. On the Target Driver Setup dialog on the Debug tab, select the following: 

• set Port to "SW" 

• set Max Clock to "1 MHz" 

• set Connect to "Normal" 

• set Reset: 

• For PSoC™ 6, to "VECTRESET" 

• For PSoC™ 4, PMG1, and AIROC™ CYW208xx, to "SYSRESETREQ" 

• enable Reset after Connect option 
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5. Select the Flash Download tab and select "Reset and Run" option after download, if needed: 

 

6. Select the Pack tab and check if "Cypress.PSoC6_DFP" is enabled: 
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4.2 To use J-Link debugger with PSoC™ MCUs 

1. Make sure you have J-Link software version 6.62 or newer. 

2. Select the Debug tab in the Options for Target dialog, select J-LINK / J-TRACE Cortex as debug adapter, and 
click "Settings": 

 

3. If you see the following message, click OK in the Device selection message box: 
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4. Select the appropriate target in Wizard: 

 

5. Go to Debug tab in Target Driver Setup dialog and select: 

• set Port to "SW" 

• set Max Clock to "1 MHz" 

• set Connect to "Normal" 

• set Reset to "Normal" 

• enable Reset after Connect option 
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6. Select the Flash Download tab in Target Driver Setup dialog and select "Reset and Run" option after 
download if needed: 

 

4.3 To use J-Link debugger with XMC7000 devices 

4.3.1 Program set-up instructions 

1. Select the Debug tab in the Options for Target dialog, select "J-LINK / J-TRACE Cortex" as the debug 
adapter, and click Settings. 
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2. On the Debug tab in the Cortex J-Link/JTrace Target Driver Setup dialog, select "SW" for Port, 2 MHz for 
Max Clock, and "Connect under Reset" on the Reset pull-down menu, and then click OK. 

 

3. Select the Utilities tab in the Options for Target dialog and deselect the Update target before Debugging 
check box. 
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4.3.2 Debug set-up instructions 

1. Select the Debug tab in the Options for Target dialog, select "J-LINK / J-TRACE Cortex" as the debug 
adapter, and click Settings. 

 

2. On the Debug tab in the Target Driver Setup dialog: 

− Port: select "SW"  

− Max Clock: select 2 MHz  

− Reset pull-down: select "Normal," "Core" or "Reset Pin" 

− Download Options: enable "Verify Code Download" and "Download to Flash" 

 

4.4 Perform ETM/ITM trace 

Refer application note AN235279 - Performing ETM and ITM trace on PSoC™ 6 MCU for details. 

https://www.infineon.com/dgdl/Infineon-AN235279_-_Performing_ETM_and_ITM_trace_on_PSoC_6_MCU-ApplicationNotes-v02_00-EN.pdf?fileId=8ac78c8c8412f8d301841dcadfba632e
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4.5 Program external memory 

1. Download internal flash as described above.  

Notice "No Algorithm found for: 18000000H - 1800FFFFH" warning. 

2. Select the Flash Download tab in Target Driver Setup dialog and remove all programming algorithms for 

On-chip Flash and add programming algorithm for External Flash SPI:  

 

 

3. Download flash. 

Notice warnings: 

• No Algorithm found for: 10000000H - 1000182FH 

• No Algorithm found for: 10002000H - 10007E5BH 

• No Algorithm found for: 16007C00H - 16007DFFH 
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4.6 Erase external memory 

1. Select the Flash Download tab in Target Driver Setup dialog and remove all programming algorithms for 
On-chip Flash and add programming algorithm for External Flash SPI:  

 

 

2. Click Flash > Erase in menu bar. 
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5 Multi-core debugging 

This section explains how to set up multi-core debugging in the µVision IDE.  

5.1 Supported debugger probes 

• KitProg3 onboard programmer 

• MiniProg4 

• ULINK2 

• J-Link 

5.2 Opening µVision multi-core projects 

After you create a ModusToolbox™ multi-core application for use with µVision, do the following: 

1. Navigate to ModusToolbox™ project directory for one of the cores and double-click project description file 

(either *.cprj or *.cpdsc depending on µVision version). 

The first time you do this, a dialog may pop-up offering to install missing CMSIS-Pack. Click Yes and the 

pack will be installed. 

2. Repeat the same process for the CM4/CM7 project(s). This will create and open µVision projects. 

5.3 Building µVision multi-core projects 

Once all projects are open, go ahead and build each one using Project > Build target. 

5.4 Debugger configuration 

Next, configure projects to launch multi-core debugging. 

5.4.1 Configure CM0+ project 

1. Go to Project > Options for Target <target_name>, switch to the Debug tab, select the applicable debug 
probe (CMSIS-DAP or J-Link) as shown: 

 

• If using ULINK2, select the CMSIS-DAP Debugger option as the debug probe, because the ULINK2 driver 

does not support multi-core debugging. 

2. Click the Settings button to configure the target driver. 

• If you select the J-Link probe, a pop-up window might display reporting that the device is unknown to 

J-Link software. 
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• If so, click OK and select the device manually in the opened Target device settings dialog. For XMC7200 

devices, there will be three aliases, each dedicated to a separate core. 

 

3. Switch to the Flash Download tab, select the Erase Sectors radio button, and select the Program, Verify, 
and Reset and Run check boxes.  

 

4. Click OK to close the Target Driver Setup dialog. 

5. Next, configure the project so that it also programs other image(s) from the CM4/CM7 project(s). Do this 

using the *.ini file. 

a. Create a new empty file named load_cmx.ini and save it inside the CM0+ project directory. 

b. Add a LOAD command with a path to the CM4/CM7 images. For example: 

LOAD "..\\proj_cm4\\proj_cm4_Objects\\proj_cm4.axf" 

c. Add as many LOAD commands for all the CM4/CM7 projects as you have. 

6. Go to Project > Options for Target <target_name>, select the Utilities tab, and specify the created 
load_cmx.ini file in the InitFile edit field. 

 

7. Switch to the Debug tab, and click the Settings button. 

The configuration settings are different for CMSIS-DAP/ULINK2 and J-Link. Refer to the following sections 

for the applicable options: 

• CMSIS-DAP/ULINK2 Target Driver Setup – Use the following options: 

• Port: SW 

• Max Clock: 1 MHz 
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• Connect: Normal 

• Reset: SYSRESETREQ 

 
 

• J-Link Target Driver Setup – Use the following options: 

• Port: SW 

• Max clock: 1 MHz 

• Connect: Normal 

• Reset: Normal 

 

That completes configuring the CM0+ project. The next step is to configure CM4/CM7 project(s). 

5.4.2 Configure CM4/CM7 project 

1. Go to Project > Options for Target <target_name>, switch to the Utilities tab, and deselect the Update 
Target before the Debugging check box. 

 

2. Switch to the Debug tab, select the applicable debug probe (CMSIS-DAP or J-Link). 
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• If using ULINK2, select the CMSIS-DAP Debugger option as the debug probe, the ULINK2 driver does 

not support multi-core debugging. 

3. Click the Settings button to configure the target driver. 

4. On the Target Driver Setup dialog, switch to the Flash Download tab, select the Do not Erase radio button, 
and deselect the Program, Verify, and Reset and Run check boxes.  

 

5. Switch to the Debug tab.  

The configuration settings are different for CMSIS-DAP/ULINK2 and J-Link. Refer to the following for the 

appropriate options: 

• CMSIS-DAP/ULINK2 Target Driver Setup – Use the following options: 

• Port: SW 

• Max Clock: 1 MHz 

• Connect: Normal 

• Reset: VECTRESET 

• Reset after Connect check box: deselected 

 

 

• J-Link Target Driver Setup – Use the following options: 

• Port: SW 

• Max Clock: 1 MHz 

• Connect: Normal 

• Reset: Core 

• Reset after Connect check box: deselected 
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6. Click OK to close the Target Driver Setup dialog. 

7. Save the project(s). 

5.5 Launching multi-core debug session 

To launch a multi-core debug session, all your µVision projects must be opened in separate IDE instances. 

1. Open a µVision IDE session with the project for the CM0+ core and start debugging by pressing Debug > 

Start/Stop Debug Session. This will program all images, reset the target, and halt at the beginning of the 
CM0+ project main(). 

2. Repeat the same process for the CM4/CM7 core(s). This will attach the running CM4/CM7 core that will be 

spinning in the boot code until the CM0+ project starts it. 

Note: Ensure both projects are built before launching a debug session. 
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For dual-core MCUs, the projects will be similar to these images:  

 

The left side of the screen shows a µVision IDE instance attached to the CM0+ core. The right side shows the 

CM4 core has not started yet. Once the Cy_SysEnableCM4() function on the CM0+ core has been executed, 
the CM4 will start executing its application. You can step through the code by switching back and forth between 

the two µVision IDE instances. 
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6 Patched flashloaders for AIROC™ CYW208xx devices 

To enable support for different QSPI settings, the ModusToolbox™ QSPI Configurator patches flashloaders and 
stores files for them in the application directory. When exporting such applications to Keil µVision, these 

patched flashloader files must be copied into the appropriate directory. 

1. Copy the CYW208xx_SMIF.FLM file.located in the <app-dir>\libs\<Kit-
Name>\COMPONENT_BSP_DESIGN_MODUS\GeneratedSource directory. 

2. Paste the flashloader file to the C:\Program Files\IAR Systems\Embedded Workbench 
9.0\arm\config\flashloader\Infineon\CYW208XX directory. 

3. Also, to use the SEGGER J-Link debugger, paste the CYW208xx_SMIF.FLM file to the C:\Program 

Files\SEGGER\J-Link\Devices\Cypress\cat1b directory. 
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Revision Date Description 

** 2023-05-15 New document. 

*A 2023-06-02 Removed obsolete instructions for customizing linker scripts. 

*B 2024-01-25 Updates for version 3.2.0. 

Removed Python. 

Add instructions for CYW20829 devices. 

Added link for ETM/ITM trace instructions. 
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